MIXW3.1 MACROS

The following Macro commands are correct as at version 3.1
Collated from the help file by Dave G3VFP updated by Colin 2EOBPP

Text

<CALL> Insert the callsign of other station as in log

<NAME> Insert the name of the other station operator as
in log

<QTH> Insert the QTH of the other station as in log

<WWLOC> Insert the name of other station WWLOC

<RSTR> Insert received RST

<RSTS> Insert sent RST

<NOTES> Insert the Notes field as in the log

<NRR> Insert Exchange received

<NRS> Insert Exchange to send

<DATE> Insert the current date

<TIME> Insert the current UTC time

<LOCALTIME> Insert current local time

<STARTTIME> Insert QSO start time

<CTIME> Insert time in HHMM format

<MYCALL> Insert your callsign as configured in Personal
Data

<MYMAINCALL> Insert your callsign without /P etc

<MYNAME> Insert your name as configured in Personal Data

<MYQTH> Insert your QTH as configured in Personal Data

<MYWWLOC> Insert your WW Locator as configured in Personal
Data

<PREVCALL> Insert other station Callsign of last QSO saved

<PREVCTIME> Insert <CTIME> of last contest QSO saved

<PREVNAME > Insert other station Name of last QSO saved

<PREVNRR> Insert Exchange received of last QSO saved

<PREVNRS> Insert Exchange sent of last QSO saved

<PREVQTH> Insert other station QTH of last QSO saved

<PREVRSTR> Insert received RST of last QSO saved

<PREVRSTS> Insert sent RST of last QSO saved

<SELCALL> Insert other station Callsign of selected logged
QSO

<SELNAME> Insert other station Name of selected logged QSO

<SELNRR> Insert Exchange received of selected logged QSO

<SELNRS> Insert Exchange sent of selected logged QSO

<SELQTH> Insert other station QTH of selected logged QSO

<SELRSTR> Insert received RST of selected logged QSO

<SELRSTS> Insert sent RST of selected logged QSO

<CR> Insert Carriage Return

<CRLE> Insert Carriage Return then Line Feed

<LF> Insert Linefeed

<CTRL-x> Insert Ctrl-A - Ctrl-Z (as defined by x)

<TAB> Insert tab symbol (same as tab key)

<[> Insert < character

<1> Insert > character

<GA> Insert GM GA or GE depending on time at Call
station

<GAL> As <GA> but use long phrase (Good Morning,
Afternoon or Evening)

<IMD> Insert the current IMD if IMD is fixed on
the statusbar

<KHZ> Insert current frequency in Khz

<KHZ :n> Insert current frequency in Khz to n decimal
places

<MHZ> Insert current frequency in Mhz

<MHZ :n> Insert current frequency in Mhz to n decimal
places

<MODE> Insert current mode

<QSOBEFOREDATE> Insert previous QSO for this band and mode
date
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<QSOBEFORETIME> Insert previous QSO for this band and mode
time

<ANYQSOBEFOREDATE> Insert date of last QSO with this call

<ANYQSOBEFORETIME> Insert time of last QSO with this call

<ANYQSOBEFOREBAND> Insert band of last QSO with this call

<ANYQSOBEFOREMODE> Insert mode of last QSO with this call

<QSONR:BAND>

Insert this band QSO number

<QSONR:MODE>

Insert this mode QSO number

<QSONR> Insert this QSO number

<WX> Insert weather data as input with <WX?>
<MILES> Insert distance in miles

<DIST> Insert Distance in km

<AZ> Insert azimuth

<CWID:DEFAULT>

Set CWID as defined in Personal Data

<CWID:text>

Set CWID to text

<CWID>

Insert CWID

<FILE>

Insert contents of file
selection dialogue)

(opens file

<FILE:filename>

Insert contents of filename

<TEXTFILE>

Insert text from file
dialogue)

(opens file selection

<TEXTFILE:filename>

Insert text from file filename

<RANDOM: filename>

to simulate live typing

Insert random string from a file.

Designed

<INIFILE:file,section,name>

Insert data from inifile

file, section [SECTION], name Name=

<VER> Insert Version Number

Program

<TX> Switch to TX mode immediately

<TXE> Switch to TX mode when the RX carrier drops

<TXTOGGLE> Toggle between TX and RX

<RX> Switch to RX when encountered in the TX data
stream

<RXANDCLEAR> Switch to RX when encountered in the TX data
stream and clear TX window

<RXE> Switch to RX mode when all TX data is
transmitted

<ACALL> Allows call changing on the fly

<CLEARQSO> Erase the data in the current QSO line

<CLEARRXWINDOW> Clear RX window

<CLEARTXWINDOW> Clear TX window

<CLEARWINDOW> Clear current window

<CURSOR:n> Position cursor at field n of the log file

<CURSOR:TX>

Position the cursor in the TX

window

<DTMF:abcd>

Send DTMF sequence

<ESCAPE>

Same as escape key

<EXEC:command>

Execute a program or command

<EXT:command>

Run an external program or command

<FILTER:name>

Turn filter on

Options include NONE, PASS,

NOTCH, NOISE

<FIXSTARTTIME> Set current time as QSO start time in log
<GRABCALL> Grabs calls from stack
<LASTCALL> Grabs the last call received

<SHOW:name>

Show Toolbar

<HIDE:name>

Hide Toolbar
The following toolbars can be
the SHOW and HIDE Macros:

toggled with
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CONTROLBAR, LOGBAR, CATBAR, TUNINGBAR, TNC,
WORLDMAP, STATUSBAR, DXCLUSTER, CALLBOOK,
BEACON, TELNET, CONTESTSTATS, QUICKSEARCH

<INPUTVOLUME> Set the soundcard input volume using the
Windows Volume Control

<OUTPUTVOLUME> Set the soundcard output volume using the
Windows Volume Control
There maybe problems with <INPUTVOLUME> and
<OUTPUTVOLUME> in the latest windows
versions

<MARKERS : XX, VY, ...> Add marker lines to the waterfall/spectrum

at xx,yy etc (up to 5) fqg

<MARKERS : OFF>

Remove all marker lines

<MODE : mode>

Set mode to Mixw mode

<MODEADD :mode>

Set mode to additional mode

<MODETNC :mode>

Set mode to TNC mode

<NEWRXWINDOW:audiofqg:mode>

Create RX mode window at audiofg

<NEWRXWINDOW:audiofqg>

Create RX current mode window at audiofg

<NEWRXWINDOW> Create new RX window in current mode and fqg
<CLOSERXWINDOWS> Close all open extra RX windows

<PTTOFE> Switch PTT off

<PTTON> Switch PTT on

<PTTSWITCH> Toggle the PTT

<BEEP:0FF> Turn the PC Beep off

<BEEP:0ON> Sound the PC Beep

<SAVEQSO> Save QSO data

<SCRIPT:filename> Run script from filename

<ASSCRIPT> Run following text as a script file

<TELNETSCRIPT:filename>

Run filename as telnet script

<TNCSCRIPT:filename>

Run script for 2nd TNC from filename

<SEEKLEFT> Initiate a seek left

<SEEKRIGHT> Initiate a seek right

<SENDEQSL> Send current QSO to eQSL. Prompts for
password

<SENDEQSLNP> Send current QSO to eQSL with no prompt

<QSLPRINT> Add current QSO to the QSL print queue
Use QSLprint to print card or label

<REPLAY> Replay the sound history

<REPLAY :n> Replay n seconds of the sound history

<STARTRECORD> Start a wav recording

<STARTRECORD: filename>

Start wav recording to filename

<STARTRECORD: filename.mp3>

Start mp3 recording to filename (requires
lame enc.dll)

<STARTRECORD2> Start wav recording from 2nd rx window
<STOPRECORD> Stop recording

<WAVE:filename> Play filename as a .wav file
<RXLOGSTART> Start RXLog (opens RXLog file select

dialogue)

<RXLOGSTART:filename>

Start RXLog using filename

<RXLOGSTOP> Stop RXLog

<SNAPNOW> Do snap now

<STARTSCAN> Starts the scan feature

<STOPSCAN> Stops the scan feature

<TOGGLECATPORT> Toggle the CAT port Enable/Disable
<TOGGLEPTTPORT> Toggle the PTT port Enable/Disable
<TOGGLESOUNDDEV> Toggle the sound device Enable/Disable
<TUNE> Send a tuning signal (ESC key aborts)
<TUNE:nn> Send a tune signal for nn seconds

<WKDIGNOREBEFORE:date time>

QSO is ignored before specified time

<WKDPERIOD:nn>

QSO is ignored until nnn minutes has elapsed

<CAPITALSONLY:x>

Switch capitals only (x = 1 on, x = 0 off)
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<WORDMODE : x>

Switch word mode (x = 1 on, x = 0 off)

<SHOW:RIGEXPERTS>

Display Rigexpert devices connected to PC

<YAPPRECV> YAPP receive
<YAPPSEND: filename> YAPP send filename
<YAPPSEND> YAPP send

<ALERT:text>

Display message box with text. Need to
action OK to continue

<SENDSPOT> Send spot to DX cluster if DX cluster is
open

<GOOGLEEARTH:<SELCALL>> Display map position of selected logged QSO
call

<GOOGLEEARTH:<CALL>>

Display map position of current QSO call

<LANG_ >

Change name of a macro depending on current
callsign

Frequency

<FQ:fg in kHz>

Sets the transceiver frequency

<zFQ:fq in kHz>

Set the transceiver zero-beat frequency

<JUMPTOTXFEFQ>

RX frequency jumps to TX frequency

<ALIGN:fqg in Hz>

Aligns on the specified audio frequency

<AUDIOFQ:fqg in Hz>

Sets the audio frequency

<BOOKMARK>

Toggles the Bookmark on/off

<BMERASE>

Clears all marks on this frequency

<CATCMD: text command>

Sends the text command to the transceiver

<CATCMDDDE: text command>

Sends text via DDE

<CATCMDHEX:hex command>

Sends the hex command to the transceiver

<CATDISABLEVFOSYNC>

Disable VFO sync

<CATENABLEVFOSYNC>

Enable auto VFO B to A

<CATTRANSVERTER: (+/-)shift in hz>

Allows working with different Transverters

<CATVFOSYNCSHIFT:shift>

Set VFO sync value

<CATWAIT:ms>

CAT delay in ms

<SPSHIFT:fq in Hz>

Sets the spectrum or waterfall shift

<SPZOOM:n>

Set the spectrum or waterfall zoom (0.5, 1, 2, 3, 4
are available)

<MEMW : n> Save certain settings to memory number n (1 - 20)
<MEMR:n> Restore settings from memory number n
Macros

<MACROS: filename>

Load macros from filename
filename will be used as default macros
(instead of MixMacros.ini)

<MODEMACROS:filename>

Load macros from filename for this mode
This command sets "filename" to store macros
for this mode

<EDITMACRO:name>

Edit macro with specified name

This command brings Edit User Macro dialogue
This command can be used to edit Event
macros

<HIDETEXT>

Don't show Macro text in window

<SHOWTEXT>

Show Macro text in window

<ONQSOBEFORE : name>

Run Macro name if QSO before

<QSOCMDDDE : command>

DDE command to external program

<WX?>

Enter weather data that will be recalled by
the <WX> macro
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Mode

<AFCON> Switches AFC On

<AFCOFF> Switches AFC Off. See <LOCKRX> below

<AFC> Toggle AFC

<INVON> Turns invert on

<INVOFF> Turns invert off

<INV> Toggle invert

<SNAPON> Switches Snap On

<SNAPOFE> Switches Snap Off

<SNAP> Toggle Snap

<SQUELCHON> Switches squelch on

<SQUELCHOFF> Switches squelch off

<SQUELCH> Toggle squelch

<LOCKRX> Lock RX Frequency. Turns waterfall flag blue
Does not inhibit AFC. RX fqg may still wander

<LOCKRXTOGGLE> Toggle Lock RX

<UNLOCKRX> Unlock RX Frequency

<LOCKTX> Lock TX Frequency. Turns waterfall flag red

<LOCKTXTOGGLE> Toggle Lock TX

<UNLOCKTX> Unlock the TX Frequency

<MODESETTINGS> Displays mode settings dialogue box

<THRESHOLD> Displays the Squelch dialog box

Auto CQ

<ACQO> Pause and restores AutoCQ mode

<ACQDELAY> Set the AUTOCQ delay

<ALARM:string>

Beeps when string is received but see
<OnAlarm> event macro

<ASAUTOCQ> Initiate the following string as AUTOCQ

<AUTOCQ> Initiates the auto CQ routine as set under
Options | AutoCQ (See below)

<AUTOCQRESUME> Resume an interrupted AUTOCQ

Contest

<SP:0> Run mode on (also <SP0>)

<SP:1> Search and pounce mode on (also <SP1>)

<SP> Switch to Run mode (same as SP:0)

<OnSP0O> Execute when switch to Run mode

<OnSP1> Execute when switch to Search and Pounce

mode

<STATS:GENERATEQTC>

Send 10 QTCs

<STATS:REPEATQTC>

Repeat the same 10 QTCs

<CLEARNRR> Clear the NRR received field

<INCNRR> Increment the NRR field if it is an integer

<INT> Output depends on S&P or Run mode and
content of CALL and NRR fields

<INTELIGENT> Same as <INT>

<INTQRL> Called in S&P mode when Call is empty

<INTDE> Called in S&P mode with a new call but NRR
empty

<INTQSL> Called in S&P mode with a new call and NRR
complete

<INTCQ> Called in Run mode when Call is empty

<INTGA> Called in Run mode with a new call but NRR

empty
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<INTQB4> Called in Run mode with a previous QSO call

<INTQRZ> Called in Run mode with new call and NRR
complete

Rotor

<ROTOR:LP> Turn rotor to the Long Path for the station
in the <CALL> field

<ROTOR: SP> Turn rotor to the Short Path for the station
in the <CALL> field

<ROTOR:n> Turn rotor to the specified azimuth using n

<ROTORCMD : command>

Send command to the rotor port

<ROTORCMDHEX : command>

Send hexadecimal command to the rotor port

cw

<LANGUAGE : xxx>

Select language
A language must have a corresponding xxx.cwt
file

<FORCELANGUAGE : xxx>

Force receiving as XXX

<WPM:-n> Decrease the CW speed by n
<WPM:+n> Increase the CW speed by n

<WPM:n> Set the CW speed to n

<WPM:RX> Match the TX speed to the RX speed

<WKHEX:hex command>

Send hex command to WinKey

<WKTEXT:text>

Send text to WinKey

<WKPOT> Disable WinKey pot

<WKNOPOT> Enable WinKey pot

Hell

<SET FILTER:width in hz> Set filter width

<SET FONT:n> Set the font to n

<SET RXFQ:fg in hz> Set the RX frequency

<SET SCALE:n> Set the scale

<SET SUBMODE : submode> Set the Hell submode (FELD, FM105, FM245)

<SET

TXFQ:fg in hz>

Set the TX frequency

MFSK

<PIC:filename%2000> Sends filename in high resolution black and
white

<PIC?N> Same as selecting File->Send Picture->B/W..
opens dialog box to select picture file,
sends in black and white

<PIC?NS%C> Same as selecting File->Send Picture->
Colour...
opens dialog box to select picture file,
sends in colour

Olivia

<GET OFFSET> Get frequency offset

<GET RATE> Get sample rate difference
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<GET SN>

Get s/n ratio

<SET BW:n>

Set bandwidth in hz

<SET TONES:n>

Set number of tones

Contestia

<SET BW:n>

Set bandwidth in hz

<SET TONES:n>

Set number of tones

RTTYM

<SET BW:n>

Set bandwidth in hz

<SET TONES:n>

Set number of tones

RTTY
<LETTERS> Forces letters
<NUMBERS> Forces numbers

<SHIFT:shift in Hz>

Sets the RTTY shift in Hz

<BAUDRATE :baudrate>

Sets the baudrate

SSTV

<FONTBOLD:n>

Set font bold (n=1 on, n=0 off)

<FONTFACE :name>

Set the font face name

<FONTITALIC:n>

Set font italic (n=1 on, n=0 off)

<FONTSIZE:n>

Set the font size

<FROMCLIP>

Load picture from clipboard

<LIMITSCANLINES:n>

Send only n lines

<LOADPICTURE: filename>

Load picture with header

<LOADPICTUREONLY: filename>

Load picture only

<LOCKMODE>

Lock the SSTV mode

<PLACETEXT:x:y:text>

Place text at position x,y

<PLACETEXT:x:y>

Place cursor at position X,y

<PUTHEADER:filename>

Put filename header file

<PUTRXPICT:x0:y0:x1:y1l>

Put received picture into the specified
rectangle

<TEXTSTYLE:n>

Set current text style

<UNLOCKMODE> - Unlock current SSTV mode
Event
<OnAlarm> Execute after an <ALARM> event. Beep is

cancelled

<OnOpenTelnetWindow>

Execute after open of Telnet window

<OnCloseTelnetWindow>

Execute after close of Telnet window

<OnOpenTNCWindow> Execute after open of TNC window

<OnCloseTNCWindow> Execute after close of TNC window

<OnCR#> Execute when Enter is pressed with focus in
log field #

<OnCR> Execute when focus in log (also see <INT>)

<OnStartMixwW> - Execute when Mixw starts

<OnEndMixwW> Execute during close of Mixw

<OnStartMode>

Execute when mode is entered
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<OnEndMode> Execute on leaving current mode

<OnEnter#> Execute when band# is entered (set in
bands.ini file)

<OnLeave#> Execute when band# is exited (set in
bands.ini file)

<OnGrabCall> Execute if two same calls are received

<OnGrabCallTx> Execute when call is grabbed from keyer

<OnGrabNumber> Execute when (serial) number is grabbed

<OnSaveQSO> Execute when QSO is saved

<OnRemoveQSO> Execute when QSO i1s removed

<OnRX> Execute when RX is initiated

<OnTX> Execute when TX is initiated

<OnEscape> Execute when Escape key pressed

<OM> Execute if <NAME> is called and Name field
in the log is empty

<OnAPPCommandxx> Execute when multimedia key xx is pressed
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Further explanation on the use of MixW Macros

<CWID>

To add a CW ID to the default signoff macro you must first define it under
Personal Data. Select Configure | Personal Data. This brings up the personal
data window. Check the "use CWID" box and then enter your sign off CW ID text,
then uncheck this box to avoid sending the CWID when you don't want too. Next
add <CWID> to the end of the macro, such as, 73 <CALL> DE <MYCALL> SK<CWID>. Of
course, <CWID> can also be assigned to a separate function key, as can <TIME>
and <DATE>, but MixW's log also logs the time and date automatically. If you use
CW ID, keep in mind that while it is executing, the other station is printing
only garbage. For that reason, you might want to use CW ID only at the end of
your signoff macro.

<AUTOCQ>

Auto CQ is a very handy Macro that enables you to transmit a predetermined CQ
sequence at regular intervals. It will stop automatically when a call sign is
received (indicating that your CQ has been answered). AutoCQ must first be
configure by selecting Options | Auto CQ | Text and entering your required CQ
call. When you're done configuring this click OK to save it. Then select options
| Auto CQ | Delay and enter the required delay, in seconds, between then end of
the transmitted message and the start of the next transmission. Finally assign
<AUTOCQ> to one of your macro buttons. To automatically stop use
<ALARM:yourcall> and create the event macro <OnAlarm:ESCAPE>. This will only
stop if the response to your CQ is in the form <MYCALL> de <CALL>.

You can initiate AutoCQ in three ways: Click on the button you have assigned it
to, depress the key you have assigned it to, or select Options->Auto CQ->Start.
You will see the AutoCQ indication box appear above your cursor in the spectrum
or waterfall display. AutoCQ will cycle until the <ALARM:x> has been received in
the RX window, when it will automatically stop (MixW knows that your CQ has been
answered!) . You can manually stop AutoCQ by the Escape Key, or by Selecting
Options->Auto CQ->Stop.

By selecting Options->Auto CQ->Watch squelch AutoCQ will then only operate when
your RX is squelched, thereby avoiding accidentally transmitting over the top of
an existing QSO.

<ASAUTOCQ>

Using this Macro command at the beginning of any Macro string will define it as
the new AutoCQ text and commence to AutoCQ with it when selected. This enables
MixW to have multiple AutoCQ strings. For instance you could define one for a
contest or special event station, and still leave your default AutoCQ text for
your normal operations.

<WAVE:filename>

Plays the indicated *.WAV file. This is very handy to use as a voice Keyer for
contesting or otherwise calling CQ or other automated voice responses. Simply
record wave files using the Windows Sound Recorder (included with Windows 9x, ME
and 2000) or another digital recording program and save them as .WAV files. Then
you can configure your Macros to replay your voice as recorded automatically.
For instance the following Macro would be used for calling CQ in a contest:
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<TX><WAVE : CQCONTEST><RX>

Where CQCONTEST is the name of the pre-recorded .WAV file of my voice saying,
"CQ Contest CQ Contest CQ Contest CQ Contest, this is K4SET calling CQ Contest".
For this Macro to work, you should be in SSB, AM, or FM phone modes. Then by
initiating this Macro (by clicking on, or depressing, the the assigned function
key) MixW will automatically key your transceiver, then play your recorded voice
calling CQ through the soundcard to your transceiver's input audio, then it will
switch back to receive while you just sit by and listen for answers. You can
likewise pre-record any number of other transmissions including reports or QRZ
type end of contact calls. This can really save you voice during a long contest
or special even operation.

Note: <WAVE:filename> can also be used in conjunction with your <AUTOCQ> or
<ASAUTOCQ> Macros to use the voice keyer to automatically call CQ.

<INIFILE>

<INIFILE:file,section,name> - insert a line from an ini-file.
Suppose I have a program that measures the temperature using a sensor
outside of the house and periodically writes the value into d:\temp\sensor.ini
file:
-- start of d:\temp\sensor.ini ---
[Sensor]
Temperature=xx
Humidity=yy
Illumination=zz
-- end of d:\temp\sensor.ini ---

Then I can make a macro:

The current temperature in Kiev is
<INIFILE:d:\temp\sensor.ini, Sensor, Temperature> degrees centigrade.

Using RUN and SEARCH AND POUNCE

There are three macros to set the RUN or SEARCH AND POUNCE mode:

<SP1> sets search and pounce mode on.
<SP0> sets search and pounce mode off (run mode on).
<SP> switches between search and pounce and run mode.

When in Run mode <Run> is appended to the main Mixw window title text.

There are several macros which are dependent on each other and the contents of
certain fields in the contest log.

The output of the <INT> macro, which is called by default by the OnCR macro when
MixW is in contest mode, depends on whether Mixw is in Run or Search and Pounce
mode and the content of the CALL and RX EXCHANGE (NRR) fields as shown in the
following tables:

Search and Pounce Mode

Call NRR Typical Output Macro to Edit
-empty- | —empty- <LASTCALL><TX><CALL> de <MYCALL><RX> INTQRL
NEWCALL -—empty- de <MYCALL> INTDE

WKDCALL —empty- nothing none

NEWCALL exchange QOSL UR 599 <NRS> <SAVEQSO> INTQSL
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Run Mode

Call NRR Typical Output Macro to Edit
—empty- —empty- CQ TEST DE mycall INTCQ
NEWCALL —empty- <CALL> GA 599 001 INTGA
WKDCALL —empty- <CALL>QSO b4 QRZ INTQB4
NEWCALL exchange QSL 73<SAVEQSO> QRZ de <MYCALL> INTQRZ

Note:

The RUN and SEARCH AND POUNCE modes function whether Mixw is in contest mode or
not.

Use of <PREV>I0US

Previous data can be inserted in the transmit data stream using macros as
detailed above. It is intended for contests but does function when Mixw is not
in contest mode. The action of the PREV macros is not consistent however. For
all macros except <PREVCTIME> Mixw will search back in the log for the last data
entry for that particular log field even if the previous QSO field is blank.

For <PREVCTIME> the search back will find the last contest log entry.

<TXE> and <RXE>

The <RXE> macro can be inserted anywhere (including before <TX>) in the data to
be transmitted. This allows data to be assembled in the transmit window as
required without the requirement of an <RX> at the end of the data. Mixw will
switch to RX when all the data in the TX buffer has been transmitted.

The <TXE> macro will only set Mixw to transmit when the carrier is dropped after
the end of the previous received data. This has some limitations. If there is
another carrier (eg someone tuning on your QSO frequency) or the band is very
noisy then Mixw may not go into transmit. However it can be overridden by
clicking on the RX button in the status bar at the bottom of the waterfall which
puts Mixw into transmit mode.

Use of <LANG_>

This macro modifier makes it possible to change the contents of an associated
macro to the language of the current QSO callsign.

It makes use of the lang.ini file delivered as part of the Mixw installation.
The content of lang.ini after installation is:

[MASK]
U*=RUS
R*=RUS
F*=FRA
I*=ITA

[DXCC]
DL=GER
EA=SPA
F=FRA
JA=JAP
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As it stands this lang.ini file is assumed to be for an English speaking
installation.

The MASK section defines calls where a complete initial prefix letter assigns
the whole of that prefix group a language key. In the settings any call that
starts with U or R is assumed to be Russian Language, F is French and I Italian.
The DXCC section defines individual countries to a language key. France is
included in both sections because as well as F prefix France can also have other
letters as the first letter of a prefix (eg TM).

An example of the use of <LANG >:

The end of a QSO is:
73 <CALL> de <MYCALL> bye SK<SENDEQSLNP><SAVEQSO><RXANDCLEAR>

This could be changed to:
73 <CALL> de <MYCALL> <LANG BYE> SK<SENDEQSLNP><SAVEQSO><RXANDCLEAR>

A number of macros are created using edit macros menu:

Name :BYE
Label: doesn't matter
Text:bye

Name :FRA BYE
Label: doesn't matter
Text:Au Revoir

Name:RUS BYE
Label: doesn't matter
Text:Doswidania

Name : GER BYE
Label: doesn't matter
Text:Auf Wiedersehen

Name:ITA BYE
Label: doesn't matter
Text:Ciao

When the <LANG BYE> macro is actioned it will substitute the LANG with the
prefix language key and then insert the text in the transmit window. If there is
no prefix language entry in lang.ini the default macro BYE is used instead.

It is possible to associate multiple countries to one language. An entry in the

DXCC section OE=GER would associate Austria with the German language and a
Spanish entry could be used to link a number of countries.

Waiting or slowing macro execution

There are a number of ways of slowing down execution, to overcome timing
problems.

Executing the sequence <FQ:29600><MODE:FM> does not reliably execute on some
transceivers but
<FQ:29600><CATWAIT:300><MODE:FM> overcomes the problem.

To completely halt a macro sequence for an indeterminate period:

<macro>text<macro><ALERT:Macro pauses>Text <macro> will halt the sequence at the
<ALERT> macro until the OK button in the message box is actioned.



MIXW3.1 MACROS

CATWAIT only delays CAT command activity and the ALERT macro needs attention. To
delay a macro sequence for a fixed period the Mixw Script command sleep must be
used.

To delay a sequence for 5 seconds to allow an asynchronous action to take place
like switching off the log display at Mixw start up, to overcome a problem of
window sizes being incorrect:

<ASSCRIPT>sleep 5
runmacro “HIDE:LOGBAR”
close

This sequence is inserted as the last 3 lines of the <OnStartMixw> macro.

The <ASSCRIPT> macro tells Mixw to action all the following data using the
Script interpreter not the Macro interpreter so after the <ASSCRIPT> is actioned
no further Mixw macro format commands can be included. However Mixw Script
language allows individual macros to be executed by runmacro “MACRONAME”. The
Script commands are case sensitive, as are the Macro commands.

When the ASSCRIPT macro is executed a small window pops up. The close command
clears it.

If a sequence of macro commands is to be part delayed then the following is the
way to do it:

<TX>73 <CALL> de <MYCALL>sk <RXANDCLEAR>
<ASSCRIPT>sleep 7

runmacro “Ctrl-F5”"

close

Macro Ctrl-F5 contains:

<TX>grz grz de <MYCALL> <MYCALL> pse k <RXANDCLEAR>

If the first <RXANDCLEAR> is left out the transmitter will be left on and idling
for 7 seconds.

The parameter to sleep is in seconds.

Multimedia keyboard support

If Mixw is being driven by a multimedia keyboard a number of other keys become
available which are actioned by:

<OnAPPCommandxx>

xx values identified:
7 - Home key

8 - Mute/Enable key

9 - Reduce volume key

10 - Increase volume key
11 - Fast forward key
12 - Fast reverse key

13 - Pause/Stop key
14 - Play Key
15 - Mail key

When any of the multimedia keys are depressed the corresponding OnAppCommand
macro number is displayed in the status bar.

These keys will only work if the window focus is on the main Mixw window.
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A warning. The sleep key (if the keyboard has one) cannot be used.

Creating or Changing Macros

The contents of macros can be changed by a number of different methods.

The Macro name is the key combination (eg Shift-F8) or the event name not the
label name.

Use the Mixw menu Configure->Default Macros (or Macros for this mode) and select
Edit from the file
selection box.

Right Click on the Macro button to bring up the Edit user macro box. This method
cannot be used to edit

the 5 'Maths' key macros (Gray+, Gray-, Gray*, Gray/ and INS), the Search and
Pounce/Run integral macros

nor the Event Macros.

Use the <EDITMACRO:macroname> macro
Use <macroname?>

This will bring up a small text input box. Input or change the text as required.
Using this method of creating or changing a macro has limitations. If you press
the Enter key whilst the focus is in the text area the edit will terminate and
the macro will be executed 'as is'. It is not possible to create extra lines for
the macro being changed and if it is being created only one line is possible.
However by use of <CRLF> multiple transmitted lines can be created.

Use <macroname> to execute the macro if it is being created/changed as an event
macro.

An example in the macro list is <WX?>
A WARNING

If an attempt is made to use a text editor to edit the raw macro files it is
possible Windows will corrupt the file when it is written back. This will occur
if a 'special' character (eg the temperature degree symbol) is included in a
macro text. Some text editors write the data back and include special characters
at the start of the file, invisible to a text editor but confusing to Mixw and
the default macro set are now appended to the back of the macro file and the
user has 'lost' their macros.

REMEMBER BACK UP ALL YOUR MACRO FILES.



